PDA

View Full Version : G6ET off song SOS



Bula2U
20th May 2013, 07:14 PM
Bula all,
Sorry if not posting in the right bin but I'm new and I'm a Kiwi so double wammed.

I just scored a 2008 G6ET. 32000ks. Sweet number indeed.
However, it just has no balls. Turbo whistles lovely but almost no noticeable boost.
Call me unko, but am at least barking up the right tree to assume its been detyned electronically .... Rather than its "defective".

Appreciate any feedback before I call the local dealer.

Btw, I live in Suva, Fiji and this black diamond is the only one of its kind here.

Cheers,

HSE2
20th May 2013, 09:39 PM
Welcome to the forum mate.

Very hard to know without some sort of guide.

I would have thought its unlikely to have been detuned but I think the best action is to call your dealer and have it checked out.

I am guessing as its the only one of its kind the dealership might have to contact Ford for information but that should be manageable.

VZTRT
20th May 2013, 11:32 PM
Have a look at the piping as it could be loose.

Bula2U
21st May 2013, 09:04 PM
Cheers guys. Was indeed a disconnected duct up front, luckily it hadn't dropped the sleeve and was sorted in a minute.
Now if I can just find 95 octane ill be fully restored.

HSE2
21st May 2013, 10:16 PM
That's great news and good result. Well done VZTRT very nice get!

VZTRT
22nd May 2013, 08:42 AM
That's great news and good result. Well done VZTRT very nice get!

There's been a few people who have had this problem. Worth a check.

HSE2
22nd May 2013, 09:33 AM
There's been a few people who have had this problem. Worth a check.

Well as we are such a small forum your assistance here was greatly appreciated